Workbench User Guide > Getting started > Basic tutorial > Bookmarks

Adding and viewing bookmarks

The Workbench allows the bookmarking of individual files or locations within a file. This section will demonstrate how to set several bookmarks and how to view them using the Bookmarks view.

  1. From the menu bar, select Window > Show View > Bookmarks. The Bookmarks view appears in the Workbench. 

  2. Edit the file JanesFile.txt.

  3. Position the cursor over the editor's marker bar next to any line in the file. Then, from the context menu on the marker bar, select Add Bookmark.

    Bookmark Menu

    When the Add Bookmark dialog opens type in a description for this bookmark. Type in "My Bookmark".

  4. Notice that a new bookmark appears in the marker bar.

    Editor with bookmark

    The new bookmark also appears in the Bookmarks view.

    Bookmark view

  5. In one of the navigation views select the file JanesText.txt. From the main Workbench menu select Edit > Add Bookmark.

    This will bookmark the file using the filename to describe the bookmark. Observe the Bookmarks view now contains two bookmarks.

    Bookmark view