Working with cheat sheets

Eclipse provides cheat sheets to guide you through some of its application development processes. Each cheat sheet is designed to help you complete some task, and it lists the sequence of steps required to help you achieve that goal. As you progress from one step to the next, the cheat sheet will automatically launch the required tools for you. If there is a manual step in the process, the step will tell you to perform the task and click a button in the cheat sheet to move on to the next step. Also, relevant help information to guide you through a task is retrieved in a single click so that lengthy documentation searches will no longer be required.

A composite cheat sheet is another kind of cheat sheet that provides guidance for larger tasks or a group of related tasks.

Launching a cheat sheet

To launch a cheat sheet from the Workbench

  1. Select command link Help > Cheat Sheets from the menu bar. If this command is not in the menu, it can be added from Window > Customize Perspective > Commands, and check Cheat Sheets. Accessing Cheat sheet via Help menu
  2. The available cheat sheets are listed, select one and click OK. Alternatively if you know the location of a cheat sheet content file on your file system or on the web you can enter its path.

The cheat sheet opens as a view. At any time, only one cheat sheet is open and active. When you launch a cheat sheet, any opened cheat sheet is closed before the new one is opened. The completion status of closed cheat sheet is saved.

The cheat sheet has a toolbar at the top right edge. These icons appear in the toolbar:

Note that some cheat sheets can also be launched from the welcome page by first selecting Tutorials and then selecting one of the tutorials.

Starting the cheat sheet

Each cheat sheet has a list of steps and it always begins with an Introduction step. When you launch a fresh cheat sheet, the Introduction step is expanded so that you can read a brief description of the cheat sheet. To start working with the cheat sheet, click Click to Begin Click to Begin button in that step. The next step is expanded and highlighted. You should also see one or more actions buttons, such as Click to Perform Click to Perform button in the highlighted step. You can now begin working through the tasks using the cheat sheet. At any time, the only highlighted step in the cheat sheet is the current step.

Restarting the cheat sheet

Any time after starting a cheat sheet, you can restart from the first step by clicking Click to Restart Click to Restart button in the Introduction step. If you have already created some artifacts, you will have to manually clean up the workspace before restarting the cheat sheet.

Progressing through the steps

In the current step, when you click Click to Perform Click to Perform button, a tool (which can be a wizard), will be launched and you will be required to work with that tool. When you finish working with that tool, the next step is automatically highlighted and it becomes the current step. When the current step is a manual task, you will need to perform the work and click Click to Complete Click to Complete button to move to the next step. A check mark Check mark icon appears in the left margin of each completed step.

Getting help information for tasks

To get step-by-step instructions for that step, click the help link Help Link Icon in the step before you click Click to Perform Click to Perform button, and the step-by-step instructions on how to work with that tool will be displayed in the Help window.

Additional help for entry fields in the tool or wizard may be available by focusing on the field (use the Tab key to position to that entry) and pressing F1.

Skipping a step

If a current step has a Click to Skip option Click to Skip button, then it is an optional step. You must click Click to Skip Click to Skip button to skip the current step, when you do, the step will have the skip mark Skip mark icon in the left margin. If the task does not present Click to Skip, you must perform that step and you cannot skip it.

Redoing a step

You can redo any step that you may have completed or skipped in the current cheat sheet. To redo the step, expand the step by clicking its expand Expand Iconicon and then clicking Click to Redo Click to Redo button. After redoing a step, the cheat sheet will continue from the redo step.

Closing the cheat sheet

When you finish the last step in a cheat sheet, it automatically restarts. You can also close the active cheat sheet by clicking the close icon Close icon in the cheat sheet's toolbar. The active cheat sheet saves its completion status when it is closed so that you can continue where you left off at a later time.

Working with composite cheat sheets