Incompatibilities between Eclipse 4.5 and 4.6

Eclipse changed in incompatible ways between 4.5 and 4.6 in ways that affect plug-ins. The following entries describe the areas that changed and provide instructions for migrating 4.5 plug-ins to 4.6. Note that you only need to look here if you are experiencing problems running your 4.5 plug-in on 4.6.

See also the list of deprecated API removals for this release.

  1. StructuredTextProcessor works in all locales
  2. Plug-in fragment org.eclipse.core.filesystem.java7 was merged into org.eclipse.core.filesystem
  3. org.eclipse.equinox.bidi major version increased to 1.0.0

1. StructuredTextProcessor works in all locales

What is affected: Clients that call org.eclipse.equinox.bidi.StructuredTextProcessor#*process*(..) methods.

Description: The process/deprocess methods used to work only in certain locales, and were effectively disabled if StructuredTextEnvironment#isProcessingNeeded() returned false. This was overly restrictive and prevented bidi-aware code from working in other environments.

Action required: Clients that need to disable bidi processing should do so on a higher level. In Eclipse/JFace, bidi support is typically controlled by the application via org.eclipse.jface.util.BidiUtils#setBidiSupport(boolean) or by passing -bidi "on=y" on the command line.

2. org.eclipse.equinox.bidi major version increased to 1.0.0

What is affected: Clients that refer to org.eclipse.equinox.bidi bundle with an upper bound < 1.0.0.

Description: The org.eclipse.equinox.bidi bundle got promoted to version 1.0.0. The only functional change with respect to 0.11.0 is the change to StructuredTextProcessor.

Action required: Clients need to increase the upper bound in their dependency declarations, e.g.:

Require-Bundle: org.eclipse.equinox.bidi;bundle-version="[0.10.0,2.0.0)"

3. Plug-in fragment org.eclipse.core.filesystem.java7 was merged into org.eclipse.core.filesystem

What is affected: Features including the org.eclipse.core.filesystem.java7 fragment.

Description: Since org.eclipse.core.filesystem now requires Java 7 or higher, it can now use classes from the java.nio.file package directly without the need for a separate plug-in fragment.

Action required: Remove all references to org.eclipse.core.filesystem.java7.