Target Provisioners

This extension point is deprecated

Identifier:
org.eclipse.pde.ui.targetProvisioners

Since:
3.3

Description:

This extension point is used to register new target plug-in provisioners. Each plug-in provisioner is listed when the user attempts to add plug-ins from the PDE Target Platform's Preference Page. The selected provisioner is responsible for providing the target location which contain plug-ins the user wants to add to the Target Platform.

This extension point is deprecated. Please use the org.eclipse.pde.ui.targetLocationProvisioners extension point instead.

Configuration Markup:

<!ELEMENT extension (provisioner+)>

<!ATTLIST extension

point CDATA #REQUIRED

id    CDATA #IMPLIED

name  CDATA #IMPLIED>


<!ELEMENT provisioner (description?)>

<!ATTLIST provisioner

id    IDREF #REQUIRED

name  CDATA #REQUIRED

icon  CDATA #IMPLIED

class CDATA #IMPLIED>


<!ELEMENT description (#PCDATA)>

human-readable description of the provisioner



Examples:

The following is an example of the extension point:


   <extension
         point="org.eclipse.pde.ui.targetProvisioners">
      <provisioner
            class="org.eclipse.pde.internal.ui.shared.target.InstallableUnitWizard"
            icon="icons/obj16/metadata_repo_obj.png"
            id="org.eclipse.pde.ui.InstallableUnit"
            name="%targetProvisioner.IU.name">
         <description>
            %targetProvisioner.IU.description
         </description>
      </provisioner>
   </extension>

API Information:
Each template must provide a class that implements org.eclipse.pde.ui.IProvisionerWizard interface.


Copyright (c) 2006, 2014 IBM Corporation and others.
All rights reserved. This program and the accompanying materials are made available under the terms of the Eclipse Public License v1.0 which accompanies this distribution, and is available at http://www.eclipse.org/legal/epl-v10.html.