Plug-in Image Browser

The Plug-in Image Browser View shows information about images found inside plug-ins from your workspace or target platform.

The view is available under Open the Plug-in Image Browser View Window > Show View > Other... > Plug-in Development > Plug-in Image Browser .

Plug-in Image Browser View

To view images, select a Source.

  1. Target Platform - images from locations specified on Window > Preferences > Plug-in Development > Target Platform preference page.
  2. Running Application - images from plug-ins running in your current Eclipse installation.
  3. Workspace - images from plug-in projects open in the workspace.

By default the first 250 images will be loaded from the plug-ins and displayed. Press Show More to display the next 250 images. To increase the number of images displayed each time the button is pressed, change the Maximum images setting. You can use the Show setting to filter the view to only display images of a certain type such as icons or wizard banners.

When an image is selected, information about the image will be displayed in the details section. The reference url can easily be copied into extensions to reuse images from other plug-ins.

Related reference

PDE Views
Target Platform Preference Page