Export and Install into the Running Host

PDE provides several tools for launching plug-ins and features in your workspace. The Eclipse Application Launcher can be used to create a second running instance of Eclipse that runs the code you have in your workspace. This is commonly referred to as self-hosting. Self-hosting is a powerful debugging and testing tool. However it is sometimes necessary for code to be tested in your host, your currently running Eclipse instance. To test code in the host, you need to export and install into the running Eclipse instance.

To export plug-ins and features and install them into the host Eclipse do the following:

  1. Develop your plug-ins and features in the workspace
  2. Open the export wizard, either Open the plug-in export wizard File > Export... > Plug-in Development > Deployable plug-ins and fragments or Open the feature export wizard File > Export... > Plug-in Development > Deployable features
  3. Select your plug-ins or features to export and install
  4. Select the last option on the Destination tab Install into host. Repository. Then choose a directory to create the repository in
  5. Hit Finish. The export operation will run followed by the installation operation.
  6. If the operations completed succesfully, you will be prompted to restart. Choose to restart now
  7. Your plug-ins will be installed and running after the restart. You can see what has been installed using the Installation Details button on the About Dialog (available by going to Help > About Eclipse SDK)

Related reference

Eclipse Application Launcher
Export Wizards
Plug-in Export Wizard
Feature Export Wizard