Eclipse JDT 3.7 Plug-in Migration Guide

This guide covers migrating Eclipse JDT 3.6 plug-ins to Eclipse JDT 3.7.

One of the goals of Eclipse 3.7 was to move Eclipse forward while remaining compatible with previous versions to the greatest extent possible. That is, plug-ins written against the Eclipse 3.6 APIs should continue to work in 3.7 in spite of the API changes.

The key kinds of compatibility are API contract compatibility and binary compatibility. API contract compatibility means that valid use of 3.6 APIs remains valid for 3.7, so there is no need to revisit working code. Binary compatibility means that the API method signatures, etc. did not change in ways that would cause existing compiled ("binary") code to no longer link and run with the new 3.7 libraries.

While every effort was made to avoid breakage, there are a few areas of incompatibility or new APIs that should be adopted by clients. This document describes those areas and provides instructions for migrating 3.6 plug-ins to 3.7.