Working sets

Working sets group elements for display in views or for operations on a set of elements.

The navigation views use working sets to restrict the set of resources that are displayed. If a working set is selected in the navigator, only resources, children of resources, and parents of resources contained in the working set are shown. The problems view, tasks view and bookmarks view can all be filtered based on a working set via the Configure Contents view menu item. When using the search facility, you can also use working sets to restrict the set of elements that are searched.

Different views provide different ways to specify a working set. The views in the Eclipse SDK use the Window Working Set by default. The Window Working Set is initially empty. In order to modify the window working set you need to enable the Window Working Set command group via Window > Customize Perspective.... You can then modify the window working set via Window > Working Sets menu or via corresponding toolbar button. Views that support working sets typically use the following working set selection dialog to manage existing working sets and to create new working sets:

  Picture of working set selection dialog


When you create a new working set you can choose from different types of working sets. In the example below you can create a resource working set, a Java working set or a help working set.

  Picture of type selection page of new working set wizard


If you create a new resource working set you will be able to select the working set resources as shown below. The same wizard is used to edit an existing working set. Different types of working sets provide different kinds of working set editing wizards.

  Picture of edit page of working set wizard


Working sets may also be a part of a manual build workflow. With autobuild disabled the Project > Build Working Set menu becomes enabled. From here you are able to selectively build working sets of your choosing.

Note: Newly created resources are not automatically included in the active working set. They are implicitly included in a working set if they are children of an existing working set element. If you want to include other resources after you have created them you have to explicitly add them to the working set.

Related concepts.
Project Explorer view
Tasks view

Related tasks.
Searching for text within a file
Showing or hiding resources in the Project Explorer view