Requirements and installation

JAX-WS Tools has the following minimum requirements.

JDK Versions

Java 5.0 is the minimum required version and JDK 6.0 is supported from update 4 and later.

JAX-WS Runtime

Before creating Web service applications with JAX-WS Tools a JAX-WS runtime must be downloaded, installed and configured in the workbench.

Currently we support the Apache CXF runtime for JAX-WS development from version 2.0.6 upwards. CXF 2.1.x or greater recommended.

The Apache CXF runtime can be downloaded from the Apache CXF Downloads page.

See here for a note on using CXF 2.6.0.

Related reference

Apache CXF 2.x Preferences

Related tasks

Create a project for CXF Web services