What's New in 3.7

Here are descriptions of some of the more interesting or significant changes made to the Eclipse Platform for the 3.7 release of Eclipse. They are grouped into:

Plug-in developers will also be interested in the corresponding What's new document in the plug-in developer's guide.

Platform Changes

HPUX for GTK A new GTK port for HP-UX (32 bit) has joined the lineup of supported configurations for which SWT and Eclipse are routinely built.

hpux

GTK on AIX 32/64 Two new ports for AIX using GTK (one for 32 bit and another one for 64 bit architectures) have joined the lineup of supported configurations for which SWT and Eclipse are routinely built.

aix

Lightweight refresh on access Previous Eclipse versions relied on native refresh providers (on Windows) or a polling mechanism to keep the workspace synchronized with the underlying filesystem. This capability can be still enabled by selecting Refresh using native hooks or polling on Opens the preference page Preferences > General > Workspace.

Now a new lightweight mechanism is available. Files discovered to be out-of-sync by the workspace, for example while accessing the file content by an editor, will be automatically asynchronously refreshed. If you want to refresh files this way, go to Opens the preference page Preferences > General > Workspace and select Refresh on access.

Lightweight Refresh on Access

Back & Forward mouse buttons The Back and Forward mouse buttons now move backward and forward in the editor navigation history.
The Problems view icon shows state The Problems view icon now indicates whether the view contains warnings or errors. This is especially useful when working with maximized editor area as it allows you to see whether there are errors or warnings without going to the Problems view:

Problems view icon

When the view is a fast view, the tool tip gives the details about the number of errors and warnings.

Job image overlay in task item When the progress of long running operations is shown in the operating system task tray, the image associated with the operation is now also shown with the progress.

Progress overlay in task item

Mac standard menu items in Window menu The Window menu now sports the standard Mac menu items ("Minimize", "Zoom" and "Bring All to Front") on Cocoa.

Minimize, Zoom & Bring All to Front

Document Proxy icons in Cocoa On Cocoa, Eclipse now supports the Document Proxy icons in the title bar of the window. You can drag it to other applications or Command+click to get the folder hierarchy.

Document Proxy Icon for a Window in Cocoa

Store the encoding of derived resources separately You can now store encodings of derived resources in a separate preferences file. Usually the encodings for all files in each project are stored in one preferences file. If you are using a version control system and the preferences file is shared, the encodings for all resources are shared along with it. This new option allows you to avoid sharing encoding information for derived files, which are not typically shared in a version control system.

If you want to store encoding settings of derived resources separately, go to Project > Properties > Resource and select the Store the encoding of derived resources separately option.

Select Store the encoding of derived resources separately option

Install/Update Changes

Install software from file Sharing or persisting the set of plugins constituting your eclipse installation is now made easy by the addition of new import / export functionality. The export functionality, available from Opens the export wizard File > Export > Install > Installed Software Items to File , will create a description file of your installation. This description file can then be used to recreate the installation by using Opens the import wizard File > Import > Install > Install Software Items from File.

Export plug-ins to file

Install software from another product You can now easily install software directly from another product. Select Opens the import wizard File > Import > Install > From Existing Installation , then select the location of any locally installed Eclipse-based product. You can then select what software items from that product you want to install in the current application.

Import plug-ins from another product

Filtered install history Install states resulting from non user-initiated install operations are now filtered out of the Installation History list. For example, adding bundles in the dropins folder will no longer add extra entries to the install history. Previously, these entries were shown, but could not be reverted and the details of what changed were not shown.

Installation history

Editor Changes

'Open With' context menu for textual editors Textual editors now have an Open With context menu which allows you to open a different editor on the same input:

Open With context menu

'Shift' reverses search in Find/Replace dialog Pressing the Shift key while invoking a search in the Find/Replace dialog will temporarily reverse the current direction setting. For example, if the current direction setting is 'Forward', then Shift+Enter will do the search in 'Backward' direction.
New options for whitespace rendering in textual editors The Show Whitespace Characters feature for textual editors now provides additional options:

Show Whitespace Characters

These options can be configured by clicking the 'whitespace characters' link on the Opens the preference page General > Editors > Text Editors preference page.

Team/CVS Changes

Branch column in History view There is now a column showing branches in the History view when using CVS.

Branch Column

Compare editor shows author on left side The compare editors now also show the author on the left side:

Show left author

Note that the authors are only shown if Show the file author in compare editors is enabled on the Opens the preference page Team preference page.

Default ssh home directory on Windows The default ssh home directory on Windows platform has been changed from ssh to .ssh. This way your keys and known hosts will be shared between Eclipse and other applications by default. If you were using ssh directory before, there is no need to change your home directory manually. Eclipse will recognize it and set ssh as the home directory for you.

To check your current ssh home directory see Opens the preference page Preferences > General > Network Connections > SSH2.

Default ssh home directory

Disable capping when comparing large documents You can now disable the capping mechanism to speed up finding differences in large documents. In cases where the capping occurs, the result can either be correct or it can display too many changes, but it never misses any change. Please remember that with this option enabled, the calculation may take more time.

Apply Patch wizard

Debug Changes

Undo support for breakpoints If you accidentally removed a breakpoint from the editor's vertical ruler or the Breakpoints view, you can now get it back using the standard undo functionality - Edit > Undo Delete Breakpoint (Ctrl+Z) - in the Breakpoints view or any other view that works against the global undo history.
Edit with keyboard in Expressions view When adding or editing watch expressions in the Expressions view, you now have the option of activating the table cell for editing using the F2 key. This shortcut works for existing expressions and for the Add new expression entry.