Adopting 4.9 mechanisms and APIs

This section describes changes that are required if you are trying to change your 4.8 plug-in to adopt the 4.9 mechanisms and APIs.

  1. Direct usages of Apache Batik CSS should be upgraded
  2. Direct usages of IBM ICU4j should be upgraded
  3. Direct usages of Apache Felix Gogo should be upgraded

1. Direct usages of Apache Batik CSS should be upgraded

What is affected: Clients directly using Apache Batik CSS bundles version 1.9.1.

Description: Due to security vulnerabilities, we have updated the Apache Batik bundles used by Eclipse Platform to version 1.10.0. Previously it was using version 1.9.1. Clients that were making direct use of the Apache Batik CSS APIs version 1.9.1 should upgrade their code to work with version 1.10.0. Other clients should not be affected. See Apache Batik website for details.

Action required: Clients should:

2. Direct usages of IBM ICU4j should be upgraded

What is affected: Clients directly using IBM ICU4j bundle versions earlier than 62.1.0.

Description: The IBM ICU4j bundles used by Eclipse Platform was updated to version 62.1.0 to take advantage of support for Unicode versions 10 and 11. Previously it was using version 58.2.0. Clients that were making direct use of the IBM ICU4j APIs should upgrade and ensure their code continues to work with version 62.1.0. Other clients should not be affected. See IBM ICU4j website for details.

Action required: Clients should:

IBM

3. Direct usages of Apache Felix Gogo should be upgraded

What is affected: Clients directly using Apache Felix Gogo Runtime or Apache Felix Gogo Shell bundle versions earlier than 1.1.0.

Description: Two of the Apache Felix Gogo bundles used by Eclipse Platform to provide the OSGi console were updated to version 1.1.0. Previously it was using version Apache Felix Gogo Runtime 1.0.6 and Apache Felix Gogo Shell 1.0.0. Clients that were making direct use of the Apache Felix Gogo APIs should upgrade and ensure their code continues to work with version 1.1.0 of both bundles. Other clients should not be affected.

Action required: Clients should: